LCD Back Lighting Tutorial

by Michael Gauvin
To Create an LCD Panel

• Startup TracePro
• Go to the Insert Menu and select the Primitive Solid Menu
• Select the Block Tab and Type in the Width dialog boxes 100 for X, 10 for Y and 100 for Z.
• Now Left Mouse Click on the Insert button.
Opening the Object Tree

• To Open the Object Tree go to the **Window** Menu and select the **Split** option

• Place the mouse cursor on the opened split screen and move the new window by using the mouse to separate the window into two separate and distinct areas. One showing the Object Tree and the second the 3D viewing area.

• Left mouse clicking on any + sign in the Object tree opens the object or surface to display more information.
Adding Material Properties to the LCD Panel

- First Click on object 1 in the object tree, the object should be highlighted in blue and the object in black on the viewing area.
- To apply a Material Property right mouse click on the viewing side of the screen. The Cut, Copy, etc menu will appear. Select the Properties selection.
- After the Apply Properties menu appears select the Material Tab.
- Select the Plastic Catalog and the Polycarb material using the drop-down dialog boxes.
- Now left mouse click on the Apply button.
- The object tree should now show the Plastic Polycarb as the material applied to object 1.
Adding Surface Properties to the LCD Panel

• To add a mirror surface to the bottom of the panel you need to select surfaces 1, 2, 3 and 5 by first opening Object 1 by left mouse clicking on the + sign before the object.

• Now left mouse click on surface 1, this will highlight the surface in blue on the object tree and in black on the viewing area. Right mouse click on the viewing area to bring up the Cut, Copy, etc dialog box. Select the Properties Option.

• Now go to the Surface tab in the Apply Properties menu. Using the pull down menu find the Perfect Mirror coating and using the Apply button apply this coating to surfaces 1, 2, 3 and 5.

• Make sure your object tree looks like the one to the left.
Creating the Fluorescent Bulb

- To create the Fluorescent bulb we need to use the **Insert** Menu and select the **Cylinder/Cone** tab
- Input the radius, length and base position and rotation as shown in the dialog box at right
- Left mouse click on the **Insert** button to create the physical bulb geometry
Adding a Surface Property to the Bulb

• First left mouse click on the + sign of the object that was just created, this will open up the Object tree to display the three surfaces that make the cylinder, the left and right plane ends and the cone between the ends

• Left mouse click on Surface 0, This will highlight in blue the Surface in the object tree and highlight the object in black on the viewing screen

• Now left mouse click on the + sign of Surface 0
Adding a Surface Property to the Bulb

• Now right mouse click on the viewing area to bring up the Cut, Copy, etc.. Menu

• Select the Properties Option

• Select the Surface Tab.

• Using the Pull down Surface Property dialog box select the Fluor White coating

• Using the left mouse button click on the Apply button at the bottom of the Apply Properties dialog box.

• Surface 0 should now display the Surface Property Fluor White in the object tree as shown in the figure at right
Adding a Surface Source Property to the Bulb

- Keeping the **Apply Properties** Menu up now select the **Surface Source** Tab using the mouse

- Select for the **Source Type**, **Flux**, **Flux** of 30 Watts, set the **Number of Rays** to 10000 rays and set the **Angular Emittance** to Lambertian.

- Left mouse click on the **Apply** button to apply this source emission to surface 0 that already has the Fluor White coating.
Creating the Reflector around the Source

• Once again let's use the **Insert** Menu to create a **Primitive Solid**
• Select the **Cylinder/Cone** tab and insert a cone with the dimensions as shown in the dialog box at right.
Creating the Reflector

- We need to make a second cylinder slightly smaller than the first.
- After inserting this cone we know have two cylinders that are positioned around the bulb.
Creating the Reflector

• Now using the **Boolean Subtract** icon we will select the larger object in the object tree and then the smaller to cut one object from the other.

• To do this click on the **Boolean Subtract** Icon, then click on the Object number that is the larger cone in the Object tree, then click on the smaller object in the object tree. This should consolidate these objects into one object with 6 surfaces.

• If you make a mistake, click on the **Undo** Icon or the **Edit** Menu, **Undo** option to reverse the subtraction process and try again.

6/16/2000
Creating the Reflector

- Now let's insert a second block and use it to cut off half the reflector.
- Once again use the Insert Menu to make a block with the dimensions shown at right.
- Use the Insert button to create the object.
- Once again click on the Boolean Subtract Icon and click on the Object in the Object tree that represent the cone shaped reflector. Then click on the just created block.
- This should create the half cone reflector that we need.
Creating the Reflector

• This is the finished geometry of the reflector.
Applying a Surface Property to the Reflector

• Now using the object tree click on the object you created as the reflector.

• Now apply a surface property of Diffuse White to the object using the **Apply Properties, Surface** tab. Click the **Apply** button after selecting the button to add this surface property to the entire object, every all surfaces.

• Clicking on the + sign of the object all Surfaces should now be coated with Diffuse White as shown in the object tree at right.
Creating a dot pattern

• Now using the **Insert** Menu select the **Primitive Solid Sphere** and enter the Radius of 1 for the sphere and a position of -5 on the Y position.

• Mouse click on the Insert button to enter the sphere
Creating a dot pattern

- Now we can make the dot a scattering dot by applying the Diffuse White surface property to the surface.
- First select the Surface on the dot in the object tree.
- Now bring up the **Apply Properties** menu and select the Diffuse White coating. Left mouse click on the **Apply** button to coat the surface.
- Your object tree should show your object with the property as shown at right.
Creating a dot pattern

• First change to the X-Z view by clicking on the X-Z view icon or using the View|Profile X-Z menu selection.

• Next make sure you have selected the dot object, it should be highlighted in both the object and viewing area as shown to the right.

• Now right mouse click on the viewing area and select the Move option. It should bring up the Move Selection dialog box as shown at right.
Creating a dot pattern

• Now type in a X Center relative move of 5 into the Move selection dialog box

• Now left mouse click on the Copy button 9 times to create nine separate dots going up the X axis.
Creating a dot pattern

• Now select the middle dot. To do this left mouse click on the Select Object icon and then click on the middle dot in the viewing screen or you can left mouse click on the object in the object tree.

• Next type in -5 in the X Center box in the Move Selection box.

• Now click 9 times on the Copy button to create 9 more scattering dots.
Creating a dot pattern

- After creating a column of 19 dots we would like to copy these dots down the Z axis.

- To select the column use the **Select Object** Icon. Make sure it is depressed as shown in the figure to the right.

- Position the cursor to the left of the topmost dot in the column. Hold the left mouse key down and pull the mouse downward until it is to the bottom right of the bottom dot in the column. As you let go of the mouse button all 19 dots will be selected.

- Now use the move selection box to copy the column 9 times in the Z direction at 5 mm intervals. Do this by pressing the Copy button 9 times. The figure should look as shown to the right.
Creating a dot pattern

• Now select the middle column again using the Select Object Icon and dragging the mouse.

• Now use the Move Selection box to create 9 more columns but first enter a -5 in the Z center box. Now click the Copy button 9 times to finish the pattern.
Adding a observation plane surface

• Now, let's add an observation plane to the system. Go to the Insert Menu and select a Primitive Solid option. Now, click on the Block tab.

• Now enter in the width and position for the block as shown in the dialog box at the right.

• This surface will show us the output of our light guide.
Turning the Display of Rays off

- Since we are tracing 10,000 rays and having them scatter into 1000s of more rays it is a good idea to use less memory by turning the display of rays off before the ray trace.

- To do this go to the Analysis menu and left mouse click on the Display Rays option, the check mark should disappear that is currently in front of the Display Rays option.
Running a source trace simulation

• Now click on the icon that looks like a little red sun with rays emitting to the left.

• The program will start ray tracing 10000 rays.

• The first part of the ray trace applies all the surface and material properties and gets the system ready for a non-sequential ray trace. The audit should take between 2 and 3 minutes.
Ray Trace

- The next part of the ray trace shows a dialog box showing how long the ray trace will take and what ray is currently being traced. It should take about 10 minutes to run the simulation on a Pentium 300Mhz machine.
• Using the Analysis Menu select the ray sorting option. Change 100 to 1 in the percent of ray shown. This will reduce the number of rays shown to 1 out of every 100.

• Now turn the Display Rays option back on by left mouse clicking on the Display Rays option. Rays will now be displayed.

• We set the top display surface to be completely absorbing and most rays reach and stop at this surface. Rays going outside of this surface are shown bypassing the surface.

• The colors of each ray indicate the flux of each ray traced. Red rays have flux from 100 to 66 percent of their beginning ray flux. Green rays are between 66 and 33 percent and Blue rays are between 33 and 0 percent.
Displaying an Irradiance Map

• There are two modes to analyze systems in TracePro. Analysis and Simulation mode. Analysis mode lets the user look at Position and Angular result plots on any surface. Simulation mode lets the user look at only one surface that must be defined before a ray trace takes place. Simulation mode uses much less virtual memory.

• By default Analysis mode is on. We will now look at several irradiance maps for this system.

• First go to the Analysis Menu and select the Irradiance Options menu.

• Input the Irradiance Options as shown at the right to correctly display an Irradiance Map. Make sure you Click on the Apply Button to input the new settings.
Irradiance map explanation

- First, select the Object above the LCD panel and select the bottom surface that we made perfectly absorbing.
- Now click on the irradiance map icon to see the plot shown at right.
- The irradiance map shown at right should pop-up on the screen.
Understanding the Irradiance Options

- Notice the default Irradiance/Illuminance Options menu shown at right. This menu is available from the Analysis Menu and is used to set all the parameters for the output map.
  - The default map type is usually set to absorbed rays. If you do not see rays on a surface, click this option to incident and an irradiance/illuminance map should appear. This system is set to Radiometric units so that all output units are shown in Watts and Watts per meter squared.
  - To set radiometric units the user must set this option in the Analysis Menu option Raytrace Options.

6/16/2000 TracePro LCD Back Lighting Tutorial
Understanding the Irradiance Options

• The **Rays to plot** options set the map to either incident or absorbed rays being display when the reach the selected surface.

• If the **Normalize to emitted flux** box is checked all rays will be normalized to 1. This is a good way to figure out the efficiency of a light pipe when you have many sources.

• The foreground and background colors of the map are set using the **Color Map** option. Black&White and greyscale maps are good for sending maps over faxes or Black and White printers. Color is best for pseudo-color display.

• The **Count** option determines the number of pixels used by the map to collect rays. A count set to 20 divides the detector into a 20x20 grid of pixels and counts the rays striking each section of the grid and then totals the energy of these rays together. Larger counts show more rays and provide a more accurate view of what is happening on the map if small detail is needed. Smaller counts let the user trace less rays and get a better idea of what they system looks like from a macro perspective.

• The **Smoothing** option applies a Gaussian smoothing across the detector pixels to smooth out choppy or non-contiguous data. This is a method to trace less rays and let the Gaussian smoothing function fill-in the missing data.
Understanding the Irradiance Options

- The **Profiles** option creates the two-cross sectional plots of the map after selecting this option and pressing the **Apply button**. This will activate two boxes below and to the left of the map. Left mouse clicking anywhere on the map will now show a cross section in both profiles of a horizontal and vertical cut through the map.

- The Normal and Up Vector selection is one of the most critical options. This sets the projection plane that all rays will be collected on. If you have a doubt what the collection plane is, the program can automatically calculate the Normal and Up vector for you. Just click on the **Automatically calculate Normal and Up Vector** box. Remember you must click **Apply** before any option is applied to the map.

- The normal vector is the vector that is perpendicular to the collection plane.

- The Up vector is parallel to the vertical side of the plane.

- If the Normal and Up vector box is entered with the wrong vectors the map may look incorrect. This incorrect map may look like a slice if the selected plane is perpendicular to the correct plane or may show no results at all.